JetPack 2-1 soluciona la vulnerabilidad XSS

WordPress core 6.0 2 vulnerabilidad cross site scripting (xss)

WordPress vulnerability news es un resumen semanal de las vulnerabilidades de seguridad de plugins de WordPress más destacadas o de las vulnerabilidades reveladas que han sido publicadas (hay otras vulnerabilidades menos críticas en plugins más pequeños que desafortunadamente no aparecen en la lista).

Mantenerse al día de las vulnerabilidades de seguridad en WordPress y otros CMS es una parte importante de la seguridad. Por eso analizamos los plugins de WordPress y las vulnerabilidades recientemente reveladas para asegurarnos de que los sitios que utilizan los plugins o temas mencionados están protegidos.

Vulnerabilidad: Escalada de privilegios autenticada y eliminación de publicacionesArreglada en la versión: 6.10.2Número de sitios afectados: 160.000+Puntuación CVSS 3.0: 9.9 (Crítica – Requiere autenticación de usuario con rol de suscriptor o superior).

Vulnerabilidad: Ejecución remota de código (RCE) no autenticada a través de REST APIFijada en la versión: 9.9.7Número de sitios afectados: N/Puntuación de ACVSS 3.0: 10 (Crítico – Puede ser explotado remotamente sin ninguna autenticación.)

Vulnerabilidad: Authenticated Blind Server-Side Request Forgery (SSRF)Corregida en la versión: 6.5.3Número de sitios afectados: 10,000+Puntuación CVSS 3.0: 6.6 (Media – Requiere autenticación de usuario de rol alto como admin.)

WordPress 6.1 1 vulnerabilidades

Jetpack es un popular plugin del CMS WordPress. El soporte de Jetpack recomienda poner en lista blanca todas las direcciones IP del servidor WordPress punto com – una pila dinámica propensa a interrupciones. Además, deshabilitar toda una regla de ModSecurity por ID parece abrir más de lo necesario.

  Mostrar el último mensaje de Twitter en tu blog

Mensaje: Advertencia. XSS detectado usando libinjection. [fichero “/ruta/al/directorio/modsecurity-crs/rules/REQUEST-941-APPLICATION-ATTACK-XSS.conf”] [line “60”] [id “941100”] [msg “Ataque XSS detectado mediante libinjection”] [data “Datos coincidentes: Datos XSS encontrados dentro de ARGS_NAMES:<?xml version: <?versión xml”] [data [severity “CRITICAL”] [ver “OWASP_CRS/3.2. 0”] [tag “application-multi”] [tag “language-multi”] [tag “platform-multi”] [tag “attack-xss”] [tag “paranoia- level/1”] [tag “OWASP_CRS”] [tag “OWASP_CRS/WEB_ATTACK/XSS”] [tag “WASCTC/WASC-8”] [tag “WASCTC/WASC-22”] [tag “OWASP_TOP_10/A3”] [tag “OWASP_AppSensor/IE1”] [tag “CAPEC-242”].

Mensaje: Acceso denegado con código 403 (fase 2). Operador GE coincidente 5 en TX:anomaly_score. [archivo “/ruta/a/directorio/modsecurity-crs/rules/REQUEST-949-BLOCKING-EVALUATION.conf”] [line “91”] [id “949110”] [msg “Inbound Anomaly Score Exceeded (Total Score: 5)”] [severity “CRITICAL”] [tag “application-multi”] [tag “language-multi”] [tag “platform-multi”] [tag “attack-generic”]

WordPress 5.9 2

Esta mañana informamos sobre una vulnerabilidad XSS en WordPress 4.2, 4.1.2, 4.1.1 y 3.9.3, que permite a un atacante comprometer un sitio a través de sus comentarios. El equipo de seguridad parcheó rápidamente la vulnerabilidad y publicó la versión 4.2.1 pocas horas después de recibir la notificación.

El equipo de WordPress ha sido informado hace unas horas de un problema de XSS para el que publicaremos una actualización en breve. Se trata de un problema importante, pero el número de sitios vulnerables es mucho menor de lo que se piensa, ya que la gran mayoría de los sitios con WordPress utilizan Akismet, que bloquea este ataque. Cuando la solución esté probada y lista en las próximas horas, los usuarios de WordPress recibirán una actualización automática y estarán seguros y protegidos incluso si no utilizan Akismet.

  Músicos famosos que usan WordPress

La actualización automática se está extendiendo a los sitios en los que no se han desactivado las actualizaciones. Si no está seguro de si su sitio puede o no realizar actualizaciones automáticas en segundo plano, Gary Pendergast enlazó con el plugin Background Update Tester en el comunicado de seguridad. Se trata de un complemento compatible con el núcleo que comprobará la compatibilidad de su sitio con las actualizaciones en segundo plano y le explicará cualquier problema.

Base de datos de vulnerabilidades

Hay problemas con los drivers de AGE para Golang y Python que permiten inyecciones SQL. Esto afecta a AGE para PostgreSQL 11 y AGE para PostgreSQL 12, todas las versiones hasta la 1.1.0 inclusive, cuando se utilizan esos controladores. La solución es actualizar a los últimos drivers Golang y Python además de la última versión del proyecto CVE por @Sn0wAlice : Live-Hack-CVE/CVE-2022-45786 fecha de creación: 2023-02-04T23:33:10Z

  El triste final de una traducción-

Una neutralización incorrecta de la entrada durante la generación de páginas web (‘Cross-site Scripting’) [CWE-79] vulnerabilidad en Sling App CMS versión 1.1.4 y anteriores puede permitir a un atacante remoto autenticado realizar un ataque de cross-site scripting (XSS) reflejado en múltiples características. Actualización a Apache Sling App CMS >= 1.1.6 Proyecto CVE por @Sn0wAlice : Live-Hack-CVE/CVE-2023-22849 create time: 2023-02-04T23:33:13Z

hb-ot-layout-gsubgpos.hh en HarfBuzz hasta 6.0.0 permite a los atacantes desencadenar un crecimiento O(n^2) a través de marcas consecutivas durante el proceso de búsqueda de glifos base al adjuntar marcas. Proyecto CVE por @Sn0wAlice : Live-Hack-CVE/CVE-2023-25193 hora de creación: 2023-02-04T21:19:30Z